Guide informatique hardware En1heure.com
Articles phares : Quelle alimentation PC | Choisir son ecran LCD PC

Chercher un sujet :

Drivers ATI et nVidia

Ne restez plus bloqués, venez demander de l'aide sur l'installation ou l'utilisation de Mandriva / Mandrake Linux.
Avatar de l’utilisateur
Modérateur Linux
Modérateur Linux
Messages: 1092
Inscription: Dim Déc 19, 2004 1:21 pm
Drivers ATI et nVidiaMessagePosté: Mer Oct 19, 2005 7:36 pm

ATI a modifié sa politique. Ils livrent un programme d'install, à lancer avec ./
Une fenètre demande ensuite le type de server X, donc autant l'avoir vérifiée avant! Le tutos est bien fait.

Quelqu'un auraitil une idée de l'écart de volume mémoire occupé entre le driver "radeon" de xorg, et les drivers d'ATI ?
Avatar de l’utilisateur
Administrateur
Messages: 1066
Inscription: Mer Avr 14, 2004 2:35 pm
Localisation: /home/vincent
Drivers ATI et nVidiaMessagePosté: Jeu Oct 20, 2005 3:28 pm

Merci Piratebab :)

Si tu as une ATi, tu n'as qu'a essayer ;)
Avatar de l’utilisateur
Modérateur Linux
Modérateur Linux
Messages: 1092
Inscription: Dim Déc 19, 2004 1:21 pm
Drivers ATI et nVidiaMessagePosté: Jeu Oct 20, 2005 6:52 pm

J'ai une ATI sur ma machine mandrake, mais noyau compilé d'origine avec les drivers. Donc je ne verrai pas la différence (j'ai pas envie de repasser en vesa, puis de réinstaller! :? )
Sur ma machine dedian, j'ai une radeon 7000, pas supportée par les drivers ATI proprios.

Messages: 1
Inscription: Sam Nov 12, 2005 10:33 pm
Drivers ATI et nVidiaMessagePosté: Sam Nov 12, 2005 10:51 pm

Bonjour tout le monde , je vient juste de débouler sur ce forum (nOOb);

J'expose mon probléme:

Lorsque que j'execute ma commande rpm sa me donne:


[root@localhost manyx]# rpm -Uvh --force fglrx*.rpm
Préparation... ########################################### [100%]
1:fglrx ########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
Error:
kernel includes at /lib/modules/2.6.11-6mdksmp/build/include do not match current kernel.
they are versioned as "2.6.11-6mdkcustom"
instead of "2.6.11-6mdksmp".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Warning ***
The QT based control panel application did not load in any version.
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===
[root@localhost manyx]#

P.S: Avant de faire "rpm -Uvh --force fglrx*.rpm" j'ai fait un "/etc/init.d/dm stop" afin de stopper toutes activités Graphique


Donc en clair j'aimerai bien savoir pourquoi il me met sa au lieu de m'installer mes drivers:

"Error:
kernel includes at /lib/modules/2.6.11-6mdksmp/build/include do not match current kernel.
they are versioned as "2.6.11-6mdkcustom"
instead of "2.6.11-6mdksmp".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux"

Avant j'avais Debian et cela marcher parfaitement

Merci pour une futur reponse :p
Avatar de l’utilisateur
Modérateur Linux
Modérateur Linux
Messages: 1092
Inscription: Dim Déc 19, 2004 1:21 pm
Drivers ATI et nVidiaMessagePosté: Dim Nov 13, 2005 1:09 pm

Bonjour,
il te le dit à 2 reprises:
kernel includes at /lib/modules/2.6.11-6mdksmp/build/include do not match current kernel.
they are versioned as "2.6.11-6mdkcustom"
instead of "2.6.11-6mdksmp".


Les sources de noyau que tu as installé ne correspondent pas à ton noyau.
Installe les sources qui correspondent strictement à ton noyau.
Avatar de l’utilisateur
Administrateur
Messages: 1066
Inscription: Mer Avr 14, 2004 2:35 pm
Localisation: /home/vincent
Drivers ATI et nVidiaMessagePosté: Sam Déc 10, 2005 5:47 pm

N'ayant plus le temps ni la motivation de m'occuper du site Mandrake.en1heure.com, j'ai décidé de supprimer les pages concernant l'installation des drivers graphiques car étant obsolètes, ces pages fesaient faire des manips causants de sérieux dégats que certains débutants ne pouvaient pas réparer.

Si vous voulez, vous pouvez continuer à poster dans ce post des nouvelles concernant ces drivers voire meme les nouvelles méthodes d'installation et les liens pour télécharger ces drivers ;)

Je suis désolé pour tout ceux qui se sont fait "piégé" par mon site...

Messages: 29
Inscription: Sam Déc 10, 2005 2:22 pm
Drivers ATI et nVidiaMessagePosté: Dim Déc 11, 2005 3:04 pm

Salut,
Vous me conseillez quoi ?

J'ai une Ati Radeon 9800 pro avec Mandrake Linux 10.1 *

J'ai tapé dans ma console : xdpyinfo
Pour savoir quelle version XFree

Il me dit :

name of display: :0.0
version number: 11.0
vendor string: Mandrakelinux (X.Org X11 6.7.0, patch level 3mdk)
vendor release number: 60700000
X.Org version: 6.7.0

(Ca c'est les 5 première lignes)

Un peu en dessous il me met :

XFree86-Bigfont
XFree86-DGA
XFree86-DRI
XFree86-Misc
XFree86-VidModeExtension

* C'est quoi la difference entre X.org et Xfree ?? :oops::oops::oops:

Donc je prend quelle version du pilote Xfree86 ?

Je veux être sure de pas planter linux parceque je mettais basé sur un tuto ici je crois et plus moyen de démarrer en monde graphique ....

Je peux me baser sur quelle tuto ? (http://www.pcinpact.com/forum/index.php?showtopic=23803&st=100&#entry708783)

Merci d'avance....
(GRAVE DEBUTANT)

Messages: 29
Inscription: Sam Déc 10, 2005 2:22 pm
Drivers ATI et nVidiaMessagePosté: Mar Déc 13, 2005 3:41 pm

Enfin des nouveaux drivers sur le site ATI ?
https://support.ati.com/ics/support/default.asp?deptID=894

Most Recent Topics
1. Linux Display Drivers and Software | 12/12/2005
2. Linux x86_64 Display Driver and Software options for FireGL Products | 12/12/2005
3. Linux x86 Display Driver and Software options for FireGL Products | 12/12/2005
4. ATI Proprietary Linux x86 Display Driver 8.20.8 | 12/12/2005
5. ATI Proprietary Linux x86 Display Drivers for XFREE86 / X. Org Version 8.20.8 | 12/12/2005

Vous en pensez quoi c'est sure ?
Avatar de l’utilisateur
Modérateur Linux
Modérateur Linux
Messages: 1092
Inscription: Dim Déc 19, 2004 1:21 pm
Drivers ATI et nVidiaMessagePosté: Jeu Déc 15, 2005 11:31 am

Bonjour,
xorg est une évolution de xfree. Tu as xorg 6.7.0 d'installé, mais il utilise des font xfree

Si tu as mandriva 2006, le noyau est compilé avec des drivers récent. Ne te lance dans une install de driver que si tu as des problémes avec ta version actuelle.. Les améliorations sont souvent minimes avec les derniers drivers (il faut lire la fiche ATI pour savoir ce qu'ils ont changé).

Messages: 29
Inscription: Sam Déc 10, 2005 2:22 pm
Drivers ATI et nVidiaMessagePosté: Jeu Déc 15, 2005 1:08 pm

Bonjour,

Pour fini j'ai employé le tuto de lebarjoe sur :
http://www.pcinpact.com/forum/index.php?s=83ecc084f385731ad13f1196a4ab4628&showtopic=23803&st=100&p=708783&#entry708783

J'ai Mandrake Linux 10.1 le noyau 2.6.8.1-12mdk, version xorg 6.7
Avec une Ati Radeon 9800pro

Si ca peu aider quelqu'un pour c'est pilote ati....

J'ai eut quelque problème au début mais c'etais parceque mon noyau n'etait pas de la meme version que pour l'installe du drivers....
Précédente

Retourner vers Mandriva / Mandrake Linux



Chercher un sujet :


cron